ToME: the Tales of Maj'Eyal

Everything about ToME
It is currently Thu Dec 12, 2019 10:31 am

All times are UTC




Post new topic Reply to topic  [ 10 posts ] 
Author Message
 Post subject: Crash at startup
PostPosted: Sun Jun 20, 2010 9:28 pm 
Offline
Halfling

Joined: Sun Jun 20, 2010 9:24 pm
Posts: 111
First up, love the game from what i've seen so far. Big fan of many roguelikes and this is shapeing up to be one of the best.
But... I just downloaded Beta4 and it crashes to desktop right after character creation every time. I am running the windows binary. I also have never been able to get the mac version to run, does it need snow leopard OS or something?

Cheers,
Doug


Top
 Profile  
 
 Post subject: Re: Crash at startup
PostPosted: Sun Jun 20, 2010 10:45 pm 
Offline
Master of Eyal

Joined: Wed Jul 24, 2002 9:26 pm
Posts: 10438
Location: Angolwen
Yes it needs 10.6 (that's snow leopard right ?)

As for the crash plaese try under GDB: http://doku.t-o-m-e.net/tome4:running_tome_with_gdb

Thanks!

_________________
[tome] joylove: You can't just release an expansion like one would release a Kraken XD
--
[tome] phantomfrettchen: your ability not to tease anyone is simply stunning ;)


Top
 Profile  
 
 Post subject: Re: Crash at startup
PostPosted: Mon Jun 21, 2010 2:10 am 
Offline
Halfling

Joined: Sun Jun 20, 2010 9:24 pm
Posts: 111
Thanks for the quick reply, I'll try that and post the results.


Top
 Profile  
 
 Post subject: Re: Crash at startup
PostPosted: Mon Jun 21, 2010 4:29 am 
Offline
Halfling

Joined: Sun Jun 20, 2010 9:24 pm
Posts: 111
I can't get gdp to work. I've extracted it into MinGW folder and ran the command line but I get c:\mingw\bin\gdp.exe is not recognized as an internal or external command, operable program or batch file'
Any ideas?


Top
 Profile  
 
 Post subject: Re: Crash at startup
PostPosted: Mon Jun 21, 2010 8:11 am 
Offline
Reaper

Joined: Wed Dec 12, 2007 12:21 am
Posts: 2257
Location: New Zealand
RUn a search and see where the file is...

_________________
Regards

Jon.


Top
 Profile  
 
 Post subject: Re: Crash at startup
PostPosted: Mon Jun 21, 2010 10:05 am 
Offline
Reaper

Joined: Mon Jan 22, 2007 6:31 pm
Posts: 1534
Location: East of the sun, west of the moon
make sure you are typing gdb, not gdp?

_________________
Oliphant am I, and I never lie.


Top
 Profile  
 
 Post subject: Re: Crash at startup
PostPosted: Mon Jun 21, 2010 11:17 am 
Offline
Halfling

Joined: Sun Jun 20, 2010 9:24 pm
Posts: 111
Got it finally.
Here it is...

Starting program: C:\ToME4\new\t-engine4-windows-1.0.0beta4/t-engine.exe
[New Thread 3172.0xc60]
[New Thread 3172.0xc48]
[New Thread 3172.0xc4c]
[New Thread 3172.0xc1c]
[New Thread 3172.0xc50]
[New Thread 3172.0xc58]
[New Thread 3172.0x9a4]
[New Thread 3172.0xc80]

Program received signal SIGSEGV, Segmentation fault.
0x00000000 in ?? ()
(gdb) info stack
#0 0x00000000 in ?? ()
#1 0x0042b5af in display_map_quad (map=0x13e85c8, dx=200, dy=148,
m=0x31bf838, i=0, j=23, a=1, obscure=0 '\000') at src/map.c:411
#2 0x0042b9a6 in map_to_screen (L=0x3d45e0) at src/map.c:447
#3 0x01d8076a in ?? ()
#4 0x0046752b in luaJIT_run (L=0x3d45e0, func=0x2f9db30, nresults=-1)
at src/luajit/ljit_core.c:223
#5 0x00459e38 in luaD_precall (L=0x3d45e0, func=0x2f9db30, nresults=-1)
at src/luajit/ldo.c:281
#6 0x01d80707 in ?? ()
#7 0x00459e17 in luaD_precall (L=0x3d45e0, func=0x2f9db10, nresults=0)
at src/luajit/ldo.c:279
#8 0x0045a2d7 in luaD_call (L=0x3d45e0, func=0x2f9db10, nResults=0)
at src/luajit/ldo.c:383
#9 0x0044fbd3 in f_call (L=0x3d45e0, ud=0x22fdc0) at src/luajit/lapi.c:795
#10 0x004597c5 in luaD_rawrunprotected (L=0x3d45e0, f=0x44fba9 <f_call>,
ud=0x22fdc0) at src/luajit/ldo.c:117
#11 0x0045a610 in luaD_pcall (L=0x3d45e0, func=0x44fba9 <f_call>, u=0x22fdc0,
old_top=800, ef=784) at src/luajit/ldo.c:464
#12 0x0044fc59 in lua_pcall (L=0x3d45e0, nargs=1, nresults=0, errfunc=49)
at src/luajit/lapi.c:816
#13 0x004288ef in docall (L=0x3d45e0, narg=1, nret=0) at src/main.c:85
#14 0x00429218 in on_redraw () at src/main.c:274
#15 0x00429d74 in SDL_main (argc=1, argv=0x3d27d8) at src/main.c:655
#16 0x00495f0b in console_main (argc=1, argv=0x3d27d8)
at ./src/main/win32/SDL_win32_main.c:315
#17 0x00495fc8 in WinMain (hInst=0x400000, hPrev=0x0, szCmdLine=0x241f17 "",
sw=10) at ./src/main/win32/SDL_win32_main.c:398
#18 0x00495896 in main ()
(gdb)


Top
 Profile  
 
 Post subject: Re: Crash at startup
PostPosted: Mon Jun 21, 2010 12:29 pm 
Offline
Master of Eyal

Joined: Wed Jul 24, 2002 9:26 pm
Posts: 10438
Location: Angolwen
Ah thanks, it's the glActiveTexture call, your card does not seem to handle multitexturing (even though it's not really used anyway).
I'll fix it for next beta

What is your card?

_________________
[tome] joylove: You can't just release an expansion like one would release a Kraken XD
--
[tome] phantomfrettchen: your ability not to tease anyone is simply stunning ;)


Top
 Profile  
 
 Post subject: Re: Crash at startup
PostPosted: Mon Jun 21, 2010 4:58 pm 
Offline
Halfling

Joined: Sun Jun 20, 2010 9:24 pm
Posts: 111
I'm running it in parallels, a windows emulator for mac. It emulates a VESA 3.0 card apparently.
Thanks, D


Top
 Profile  
 
 Post subject: Re: Crash at startup
PostPosted: Mon Jun 21, 2010 8:07 pm 
Offline
Master of Eyal

Joined: Wed Jul 24, 2002 9:26 pm
Posts: 10438
Location: Angolwen
Ah that's it probably then :)

_________________
[tome] joylove: You can't just release an expansion like one would release a Kraken XD
--
[tome] phantomfrettchen: your ability not to tease anyone is simply stunning ;)


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 10 posts ] 

All times are UTC


Who is online

Users browsing this forum: Bing [Bot] and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group