ToME: the Tales of Maj'Eyal
http://forums.te4.org/

Simplified Prodigy Requirements
http://forums.te4.org/viewtopic.php?f=50&t=49633
Page 1 of 1

Author:  helminthauge [ Sat Jul 27, 2019 5:43 pm ]
Post subject:  Simplified Prodigy Requirements

The requirements fo some prodigies are simplified so you don't have to grind for them. Also removed some requirements which if you don't meet, you won't benefit from that prodigy at all. Any requirements that may involve risks are not touched.
https://te4.org/games/addons/tome/simpl ... odigy-reqs

Prodigies touched are:
Aether Permeation -- removing the 25% arcane damage resistance requirement
Armour of Shadows -- reducing the darkness damage dealt need to 50
Blighted Summoning -- removing the requirement
Cauterize -- reducing the fire damage received need to 50 and reducing the number of spell casted to 10
Corrupted Shell -- reducing the blight damage received need to 50
Elemental Surge -- removing the requirement
Endless Woes -- removing the requirement
Eternal Guard -- removing the requirement
Giant Leap -- removing the requirement
Irresistible Sun -- reducing the light/fire damage dealt need to 50
Massive Blow -- removing the requirement
Mental Tyranny -- reducing the mind damage dealt need to 50
Temporal Form -- removing the requirement of having casted 1000 spells
Vital Shot -- removing the requirement
Windblade -- removing the requirement
You Shall Be My Weapon! -- removing the requirement

Warning: this addon overloads all prodigy files, which may cause incompatibility with other addons alternating prodigies.

Author:  Zizzo [ Wed Jul 31, 2019 3:33 am ]
Post subject:  Re: Simplified Prodigy Requirements

helminthauge wrote:
Warning: this addon overloads all prodigy files, which may cause incompatibility with other addons alternating prodigies.

[sound F/X: testing] Yeah, Prodigious Progress trips over this, since it does meatball surgery on the prodigy definitions from the ToME:load hook and expects them to be their default "shape" (in particular, the missing require.special{} in Massive Blow chokes it). It's part of ZOmnibus too, so that's fairly likely to come up. I've pushed out compatibility releases for both to paper over the problem.

Author:  helminthauge [ Wed Oct 30, 2019 8:49 am ]
Post subject:  Re: Simplified Prodigy Requirements

1.6.0 updated

Page 1 of 1 All times are UTC
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/