ToME: the Tales of Maj'Eyal
http://forums.te4.org/

[1.3.0] UI Mod - Bigger fonts, ambient sound toggle, etc.
http://forums.te4.org/viewtopic.php?f=50&t=40172
Page 7 of 15

Author:  frogbeard [ Mon Apr 14, 2014 4:57 pm ]
Post subject:  Re: [1.1.5] UI Mod - Bigger fonts, ambient sound toggle, etc

Uploaded a save -new char, leveled to 10 without ever exiting, then exited to main menu, and hang upon trying to reload:
http://www.sendspace.com/file/y1r2d9

Author:  Doctornull [ Mon Apr 14, 2014 5:46 pm ]
Post subject:  Re: [1.1.5] UI Mod - Bigger fonts, ambient sound toggle, etc

After latest update, still getting an error:

Full log here: http://pastebin.com/9VUB9Rrq
Save file here: http://www.mediafire.com/download/8svcn ... fintri.zip

Code:
Using cached font   /data/font/DroidSansMono.ttf   51
[DISPLAY MODE] Tileset: shockbolt
[DISPLAY MODE] Size: 48x48
Loading tileset attachements from    /data/gfx/shockbolt/attachements.lua
[GAME] Creating FBOs
[SHADER] using permcached shader main_fbo[]
[SHADER] using permcached shader full_fbo[]
Loading savefile    /save//
Loading savefile    /save/fintri/
error deserializing   d={}
setLoaded('engine.ui.Dialog-0x26ba8920', d)
d["ui"]="metal"
d["iw"]=406
d["particles"]={}

d["focus_ui_id"]=2
d["font"]=
d["iy"]=33
d["b1"]={["w"]=64,
["tw"]=64,
["h"]=64,
["th"]=64,
}

d["ui_by_ui"]={[loadObject('engine.ui.Textzone-0x2661d9a0')]={["x"]=8,
["ui"]=loadObject('engine.ui.Textzone-0x2661d9a0'),
["top"]=3,
["y"]=36,
["left"]=3,
}
,
[loadObject('engine.ui.Button-0x2668daf8')]={["x"]=175,
["ui"]=loadObject('engine.ui.Button-0x2668daf8'),
["y"]=91,
["bottom"]=3,
["hcenter"]=0,
}
,
}

d["b2"]={["w"]=64,
["tw"]=64,
["h"]=64,
["th"]=64,
}

d["b3"]={["w"]=64,
["tw"]=64,
["h"]=64,
["th"]=64,
}

d["overs"]={}

d["w"]=416
d["h"]=140
d["focus_ui"]={["x"]=175,
["ui"]=loadObject('engine.ui.Button-0x2668daf8'),
["y"]=91,
["bottom"]=3,
["hcenter"]=0,
}

d["title_tex"]={[2]=128,
[3]=32,
[4]=1.3913043478261,
[5]=1.4545454545455,
[6]=92,
[7]=22,
["w"]=92,
["h"]=22,
}

d["color"]={["r"]=255,
["b"]=255,
["g"]=255,
}

d["b4"]={["w"]=64,
["tw"]=64,
["h"]=64,
["th"]=64,
}

d["display_y"]=352
d["mouse"]=loadObject('engine.Mouse-0x264ae078')
d["__CLASSNAME"]="engine.ui.Dialog"
d["b7"]={["w"]=64,
["tw"]=64,
["h"]=64,
["th"]=64,
}

d["ih"]=99
d["ix"]=5
d["display_x"]=432
d["__hidden"]=true
d["b9"]={["w"]=64,
["tw"]=64,
["h"]=64,
["th"]=64,
}

d["b5"]={["w"]=64,
["tw"]=64,
["h"]=64,
["th"]=64,
}

d["alpha"]=255
d["title"]="Running..."
d["first_display"]=true
d["b8"]={["w"]=64,
["tw"]=64,
["h"]=64,
["th"]=64,
}

d["__stack_id"]=1
d["frame"]={["title_x"]=0,
["ox1"]=-42,
["b5"]="ui/dialogframe_5.png",
["b6"]="ui/dialogframe_6.png",
["b7"]="ui/title_dialogframe_7.png",
["b8"]="ui/title_dialogframe_8.png",
["b2"]="ui/dialogframe_2.png",
["b9"]="ui/title_dialogframe_9.png",
["b1"]="ui/dialogframe_1.png",
["b4"]="ui/dialogframe_4.png",
["title_y"]=-18,
["title_h"]=32,
["ox2"]=42,
["title_w"]=4,
["b3"]="ui/dialogframe_3.png",
["oy2"]=42,
["w"]=500,
["oy1"]=-42,
["h"]=224,
["a"]=0.75,
["shadow"]={["y"]=15,
["x"]=15,
["a"]=0.375,
}
,
}

d["uis"]={[1]={["x"]=8,
["ui"]=loadObject('engine.ui.Textzone-0x2661d9a0'),
["top"]=3,
["y"]=36,
["left"]=3,
}
,
[2]={["x"]=175,
["ui"]=loadObject('engine.ui.Button-0x2668daf8'),
["y"]=91,
["bottom"]=3,
["hcenter"]=0,
}
,
}

d["setuped"]=true
d["key"]=loadObject('engine.KeyBind-0x26dff9a8')
d["b6"]={["w"]=64,
["tw"]=64,
["h"]=64,
["th"]=64,
}


return d   [string "d={}..."]:9: unexpected symbol near '='
Lua Error: /engine/class.lua:325: bad argument #1 to 'setfenv' (number expected, got nil)
   At [C]:-1
   At [C]:-1 setfenv
   At /engine/class.lua:325 deserialize
   At /engine/class.lua:343 load
   At /engine/Savefile.lua:395 loadObject
   At [string "d={}..."]:3252 deserialize
   At /engine/class.lua:343 load
   At /engine/Savefile.lua:395 loadObject
   At [string "d={}..."]:5 deserialize
   At /engine/class.lua:343 load
   At /engine/Savefile.lua:395 loadObject
   At [string "d={}..."]:162 deserialize
   At /engine/class.lua:343 load
   At /engine/Savefile.lua:395 loadReal
   At /engine/Savefile.lua:466 loadGame
   At /engine/Module.lua:816 instanciate
   At /engine/utils.lua:1902 showMainMenu
   At /engine/init.lua:153
   At [C]:-1 dofile
   At /loader/init.lua:196

Author:  Marson [ Tue Apr 15, 2014 4:18 am ]
Post subject:  Re: [1.1.5] UI Mod - Bigger fonts, ambient sound toggle, etc

Blarg. Thanks for the save files, guys. I feel pretty confident I found what was causing the corrupted saves and fixed it, but then I spent most of the day trying to put together a boot mod that would load previously corrupted savefiles and fix them. I feel like I'm *this* close. But like they say, the last 10% of the work takes 90% of the time.

To clarify, the fix that's in now should prevent saves from being corrupted, but won't load previously corrupted saves.

Author:  frogbeard [ Tue Apr 15, 2014 1:26 pm ]
Post subject:  Re: [1.1.5] UI Mod - Bigger fonts, ambient sound toggle, etc

I can confirm that I was able to play a character through, so far, around 15 levels with several saves/reloads, and no issues.

Author:  Marson [ Tue Apr 15, 2014 5:33 pm ]
Post subject:  Re: [1.1.5] UI Mod - Bigger fonts, ambient sound toggle, etc

frogbeard wrote:
I can confirm that I was able to play a character through, so far, around 15 levels with several saves/reloads, and no issues.

Great news. Thanks for letting me know, frogbeard.

I'm still working on a save recovery for anyone that had a character corrupted.

Author:  Marson [ Thu Apr 17, 2014 2:03 am ]
Post subject:  Re: [1.1.5] UI Mod - Bigger fonts, ambient sound toggle, etc

*headdesk*

I spent two days on it, but I don't think I'll be able to get a save recovery addon working for those characters that got corrupted. I didn't realize how protective the filesystem was. I can detect the corrupted files and have the UI and framework all working, but can't copy or rename the file. :|

Author:  frogbeard [ Thu Apr 17, 2014 12:21 pm ]
Post subject:  Re: [1.1.5] UI Mod - Bigger fonts, ambient sound toggle, etc

I know the frustration of becoming determined to fix a problem and being stymied. No worries!
How about a feature where as your paradox gets higher, all game fonts get gradually replaced by wingdings? :P

Author:  Row [ Thu Apr 17, 2014 12:29 pm ]
Post subject:  Re: [1.1.5] UI Mod - Bigger fonts, ambient sound toggle, etc

Thanks, the tooltip width of 400 is fine. Don't see why it was like 200 in the first 2.x versions. Only in the shops, it was fine to have the tooltip in the center if the width is 400. Now it is back to floating like original, but this is minor.

Author:  Marson [ Thu Apr 17, 2014 4:44 pm ]
Post subject:  Re: [1.1.5] UI Mod - Bigger fonts, ambient sound toggle, etc

frogbeard wrote:
How about a feature where as your paradox gets higher, all game fonts get gradually replaced by wingdings? :P

I'm too worn out to be evil. :lol:

Row wrote:
Thanks, the tooltip width of 400 is fine. Don't see why it was like 200 in the first 2.x versions. Only in the shops, it was fine to have the tooltip in the center if the width is 400. Now it is back to floating like original, but this is minor.

With v2, I started scaling it based on font type and size to try an make it more adaptable for lower resolutions, but being automatic doesn't account for preference. In the stores, it should be the same as it was, as I'm pretty sure I didn't use the dedicated tooltip space on that screen. If you have the tooltip set very wide while on a low resolution, the regular inventory screen may automatically use "Small Screen" now even if you have it set to "Big Screen", or move the tooltip over to the right.

Author:  Row [ Fri Apr 18, 2014 12:09 pm ]
Post subject:  Re: [1.1.5] UI Mod - Bigger fonts, ambient sound toggle, etc

Marson wrote:
In the stores, it should be the same as it was, as I'm pretty sure I didn't use the dedicated tooltip space on that screen. If you have the tooltip set very wide while on a low resolution, the regular inventory screen may automatically use "Small Screen" now even if you have it set to "Big Screen", or move the tooltip over to the right.


In the stores, in previous versions, the tooltip was in the dedicated area in the middle, like it is in the regular inventory screen. Now it is floating, like original. My setting is Big Screen.

Author:  Marson [ Wed May 07, 2014 9:59 pm ]
Post subject:  Re: [1.1.5] UI Mod - Bigger fonts, ambient sound toggle, etc

+ Targeting uses the updated UI padding so that it is more responsive to scrolling.

Author:  tokariew [ Fri May 09, 2014 3:43 pm ]
Post subject:  Re: [1.1.5] UI Mod - Bigger fonts, ambient sound toggle, etc

i have some problem, download this addon from steam workshop and it's downloading all the time when i on main menu of game.

Did tranparency of item influence somehow game speed? I get very laggy gameplay, when monster is summon, or i use some AoE spell.

Author:  Marson [ Fri May 09, 2014 6:39 pm ]
Post subject:  Re: [1.1.5] UI Mod - Bigger fonts, ambient sound toggle, etc

That's a ToME issue right now. For me, it's the Faerie addon that keeps downloading over and over.

In stock ToME, some HUD choices have transparency and some don't. You can set my addon to use the stock numbers, or go from fully transparent to fully opaque. It's possible something I did in the addon is slowing things down, but I haven't heard anything specifically. You can turn transparency off if you want to try that.

Author:  Doctornull [ Sun May 11, 2014 3:58 am ]
Post subject:  Re: [1.1.5] UI Mod - Bigger fonts, ambient sound toggle, etc

Yeah I had the re-download issue with at least three different addons. Nothing the addon makers can do about it. Maybe 1.2 will fix it.


On the subject of 1.2, if anyone is beta-testing that, you may want to REMOVE this addon.

Some of the overload files conflict with 1.2 changes, and you'll experience some needless bugs.

Author:  Marson [ Sun May 11, 2014 4:01 am ]
Post subject:  Re: [1.1.5] UI Mod - Bigger fonts, ambient sound toggle, etc

Yeah, thanks for posting that doctornull. Even if you don't get errors, you won't actually be testing 1.2 if UI Mod is installed on it.

I'm hoping to have a test-compatible version out in a few days.

Page 7 of 15 All times are UTC
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/