ToME: the Tales of Maj'Eyal

Everything about ToME
It is currently Sat Dec 14, 2019 10:57 am

All times are UTC




Post new topic Reply to topic  [ 9 posts ] 
Author Message
PostPosted: Thu Nov 21, 2019 1:36 pm 
Offline

Joined: Thu Nov 21, 2019 1:32 pm
Posts: 2
https://te4.org/games/addons/tome/grays ... onry-fixed

I'm just making a post here to let everyone know that I believe I fixed Grayswandir's Weapons Pack.

From the original postings' info:
This adds new weapon types and egos to the game.

- Tridents are unchanged, but generate more often.
- Whips can now generate normally, and their accuracy bonus now slows the target.
- Swordbreakers are weak knives that have a chance to disarm on hit, and give bonuses to dual weapon defense.
- Rapiers are 1h weapons that use dagger mastery and rely on strength, dexterity, and cunning.
- Bucklers are light shields that can greatly increase your defense and give you faster attacks against those who miss you in melee.
- Buckler offense tree at varying levels of access for 5 or so classes. Skirmishers start with a buckler.
- Spears/Greatspears are slow weapons that can attack from a distance.
- Clubs/Greatclubs are maces that can pick up mindstar egos.
- Throwing knives can be used in melee or as a short ranged attack with the shoot talent.
- Daggers will now use the higher of strength or cunning if you don't have Lethality.
- Mindslayers can now equip ranged weapons in their psionic focus slot.
- Aurastones are magic-based items that can be equipped to modify your unarmed attacks.
- Magic Weapon Mastery applies to staves, aurastones, and sceptres, and can be learned in Angolwen.


Patch 1.5 broke this addon, but I believe I fixed it. Please do not hesitate to let me know if you encounter any bugs.

The mod is also on the Steam Workshop.


Top
 Profile  
 
PostPosted: Thu Nov 21, 2019 8:52 pm 
Offline
Higher

Joined: Wed Mar 12, 2014 10:30 am
Posts: 79
I was pretty excited to see this because I used to love this addon, but the new item types are not actually appearing in my games. I make a Skirmisher and he's got nothing in his offhand. I got to around Sandworm caves without seeing any of these items types

Additionally, I occasionally crashed while loading zones, giving me this error in the log:

Code:
Lua Error: /engine/Entity.lua:917: attempt to index local 'base' (a number value)
   At [C]:-1 __index
   At /engine/Entity.lua:917 recursive
   At /engine/Entity.lua:925 recursive
   At /engine/Entity.lua:947 addTemporaryValue
   At /engine/interface/ActorTalents.lua:1104 talentTemporaryValue
   At /data-grayswandir-weaponry-fixed/talents/archery.lua:49 passives
   At /engine/interface/ActorTalents.lua:599 learnTalent
   At /mod/class/Actor.lua:4914 learnTalent
   At /mod/addons/orcs/superload/mod/class/Actor.lua:201 learnTalent
   At /mod/class/Actor.lua:3743 resolveLevelTalents
   At /mod/class/Actor.lua:3776 levelup
   At /mod/addons/orcs/superload/mod/class/Actor.lua:121 levelup
   At /engine/interface/ActorLevel.lua:145 forceLevelup
   At /engine/interface/ActorLevel.lua:63 resolveLevel
   At /engine/Entity.lua:774 resolve
   At /mod/class/Actor.lua:312 resolve
   At /engine/Zone.lua:724 finishEntity
   At /engine/Zone.lua:445 makeEntity
   At /mod/class/generator/actor/Random.lua:44 generateOne
   At /engine/generator/actor/Random.lua:127 regenFrom
   At /engine/generator/actor/Random.lua:49 generate
   At /engine/Zone.lua:1106 newLevel
   At /engine/Zone.lua:970 getLevel
   At /mod/class/Game.lua:1150 changeLevelReal
   At /mod/addons/cults/superload/mod/class/Game.lua:45 changeLevelReal
   At /mod/class/Game.lua:949 base_changeLevel
   At /mod/addons/zomnibus/superload/mod/class/Game.lua:104 changeLevel
   At /mod/class/Game.lua:2200
   At /engine/KeyBind.lua:231 receiveKey
   At /engine/interface/PlayerMouse.lua:154 mouseHandleDefault
   At /mod/class/Game.lua:2561 fct
   At /engine/Mouse.lua:71
FROM    /mod/addons/cults/superload/engine/dialogs/ShowErrorStack.lua   loading previous!
Lua Error: /engine/dialogs/ShowErrorStack.lua:41: attempt to index field 'author' (a nil value)
   At [C]:-1 __index
   At /engine/dialogs/ShowErrorStack.lua:41 init
   At /engine/class.lua:147 new
   At /engine/Game.lua:287 tick
   At /engine/GameTurnBased.lua:49 tick
   At /mod/class/Game.lua:1528


The error does mention another mod I was running, so a conflict there could be the source of the crashing on loading, but I wasn't getting any of the items to drop even with no other mods active.


Top
 Profile  
 
PostPosted: Thu Nov 21, 2019 10:40 pm 
Offline

Joined: Wed Apr 10, 2019 1:27 am
Posts: 4
I got an error that looks like it's coming from this mod.

Code:
Lua Error: /data-grayswandir-weaponry-fixed/talents/swordbreakers.lua:22: attempt to call field 'getDeflectPercent' (a nil value)
   At [C]:-1 getDeflectPercent
   At /data-grayswandir-weaponry-fixed/talents/swordbreakers.lua:22 getDamageChange
   At /data/talents/techniques/dualweapon.lua:77 callbackOnActBase
   At /data/talents/techniques/dualweapon.lua:51
   At /engine/Game.lua:323 onTickEndExecute
   At /engine/Game.lua:314 tick
   At /engine/GameTurnBased.lua:49 tick
   At /mod/class/Game.lua:1523 base_tick
   At /mod/addons/turn_separators_v2/superload/mod/class/Game.lua:45 base_tick
   At ...ons/improved_combat_text_v2/superload/mod/class/Game.lua:61
 ----------------  Stack Dump ----------------
--------------- Stack Dump Finished ---------------


This happened when entering the last level of the Wolfmire (from the Adventurer's Pack addon) and reappeared every turn until the boss in that zone (brown werewolf) was killed.

I suspect this may be because the boss was dual-wielding weapons; I don't know what base-game bosses dual-wield offhand to test with.


Top
 Profile  
 
PostPosted: Fri Nov 22, 2019 1:33 am 
Offline
Higher

Joined: Wed Mar 12, 2014 10:30 am
Posts: 79
Mousing over an aurastone gives me a lua error, and having it in my inventory prevents me from opening my inventory with a similar error.

Code:
Lua Error: /mod/class/Object.lua:792: attempt to call method 'getDammod' (a nil value)
   At [C]:-1 getDammod
   At /mod/class/Object.lua:792 desc_combat
   At /hooks/grayswandir-weaponry-fixed/descriptions.lua:63
   At [string "return function(l, self, data) local ok=false..."]:1 triggerHook
   At /mod/class/Object.lua:1143 descCombat
   At /mod/class/Object.lua:1264 desc_combat
   At /mod/class/Object.lua:1902 desc_wielder
   At /mod/class/Object.lua:1957 getTextualDesc
   At /mod/class/Object.lua:2228 getDesc
   At /mod/dialogs/ShowEquipInven.lua:54 on_select
   At /mod/dialogs/ShowEquipInven.lua:234 select
   At /mod/dialogs/ShowEquipInven.lua:93 on_select
   At /engine/ui/ListColumns.lua:437 onSelect
   At /engine/ui/ListColumns.lua:658 display
   At /engine/ui/Inventory.lua:308 display
   At /engine/ui/Inventory.lua:298 generateList
   At /engine/ui/Inventory.lua:147 generate
   At /engine/ui/Base.lua:107 init
   At /engine/ui/Inventory.lua:57 init
   At /engine/class.lua:147 new
   At /mod/dialogs/ShowEquipInven.lua:90 init
   At /engine/class.lua:147 new
   At /engine/interface/ActorInventory.lua:366 showEquipInven
   At /mod/class/Game.lua:2221
   At /engine/KeyBind.lua:237


I appreciate that you've been working on this.

Edit: I forgot to mention that this only happens when you can see unarmed damage stats, either by being a brawler or selecting the "always show glove combat properties " option.


Top
 Profile  
 
PostPosted: Fri Nov 22, 2019 5:10 am 
Offline

Joined: Thu Nov 21, 2019 1:32 pm
Posts: 2
Thank you for your feedback, everyone!

I have patched the mod a few hours ago, which should hopefully fix these issues. I'll do some more testing tonight, but I have yet to encounter these errors anymore as of the patch.

Please let me know if you see any other issues with this mod!


Top
 Profile  
 
PostPosted: Sat Nov 23, 2019 9:07 pm 
Offline

Joined: Wed Apr 10, 2019 1:27 am
Posts: 4
I'm continuing to get exactly the same error under version 1.3.

At this point I'm going to assume these two addons are incompatible.


Top
 Profile  
 
PostPosted: Mon Nov 25, 2019 11:12 am 
Offline
Higher

Joined: Sun Aug 24, 2014 7:09 am
Posts: 76
Location: A Holding Pattern on the Eidolon Plane
I've yet to see most of the new items, just the spears and bucklers so far. Checked all the stores in Last Hope and that was it.

I also ended up with an infinite load entering Trollmire 3. Had to force-quit and now the save's busted. I don't know if it's this mod or another one, but I don't actually have many since 1.6 - ZOmnibus, Acid Trees for Archmage, Dread Necro, Grove Keeper, High Guard, Steamshaper, White Monk, and of course this, and that's not an error I had until I added this. Maybe Shax generated with an artifact that the game didn't like?


Top
 Profile  
 
PostPosted: Mon Nov 25, 2019 11:11 pm 
Offline
Perspiring Physicist

Joined: Sun Sep 09, 2012 7:43 am
Posts: 5966
If you ever have to force quit, you should check the log file for the error before tying to load the inevitably broken save file. :(

_________________
My feedback meter decays into coding. Give me feedback and I make mods.


Top
 Profile  
 
PostPosted: Sun Dec 01, 2019 2:18 am 
Offline
Yeek

Joined: Wed Oct 24, 2018 3:56 am
Posts: 10
Playing a Temporal Warden with this addon appears to prevent it from auto-switching back to bow. When on melee, it grays out the shoot icon. Using a Chronomancy/Bow Threading talent will auto-switch to bow.

Without this addon I can switch automatically to bow by triggering the shoot icon.

While I did patch to 1.6.4 today, I verified by rolling a new Temporal Warden both with and without this addon enabled.

On the plus side, I did loot "Frozen Light" spear; that was cool. Character died and l lost it though :(


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 9 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group