ToME: the Tales of Maj'Eyal

Everything about ToME
It is currently Sat Jan 16, 2021 6:12 am

All times are UTC

Post new topic Reply to topic  [ 7 posts ] 
Author Message
PostPosted: Sat May 12, 2018 5:59 am 

Joined: Sat May 12, 2018 5:43 am
Posts: 45
I'll start by saying i'm new to this game, but not to rpg although I haven't played it seriously for some time now.
Further i'm coming in on the linux version and am running on Easy-pyro64-0.9.1 (an australian version of linux of the puppy linux world).
Hardware is a dell optiplex 745 with a core2duo and 4gig of ram.

after downloading and installing it to a suitable directory
I started the game
picked a halfling, rogue as my character
it started ok at Trollmire (1) and cleared that level
found the exit to level 2 and right-clicked
a screen came up saying "Loading Level" "Please wait while loading the level...."

and an hour later it's still displaying that with no sign of a drive light or other action.

Any ideas where to go from here or do I just "hang it up via the process manager" and try again.

Last edited by scsijon on Fri Jun 08, 2018 1:14 am, edited 3 times in total.

PostPosted: Sat May 12, 2018 12:14 pm 
Master of Eyal

Joined: Wed Jul 24, 2002 9:26 pm
Posts: 10738
Location: Angolwen
After one hour, yeah kill it :/
Please next time, run the game from a terminal and if this happens again past me the error that should show up in the terminal please, can't do much without :/

[tome] joylove: You can't just release an expansion like one would release a Kraken XD
[tome] phantomfrettchen: your ability not to tease anyone is simply stunning ;)

PostPosted: Sat May 12, 2018 11:30 pm 

Joined: Sat May 12, 2018 5:43 am
Posts: 45
Ok, thanks for the response, did that anyway in the end as i wanted to shutdown that box.

For referance, it's installed in /opt/games/tome-159

and after starting in a console I saw a few start bugs to begin with:
Loading WebCore: Failed loading /opt/games/tome-159/lib64/ cannot open shared object file: no such file or directory

Yet this file exists in your lib64 directory
sh: xdg-mime: command not found

I don't have one, do I need to install this package? I don't remember it in a requirement list
Module mismatch engine version boot-1.0.0 using engine te4-1.0.1
Loaded module definition for boot-1.0.0 using te4-1.0.1

and the same for example-1.1.5 and example-runtime-1.1.5
take this are general notices and not errors
[1] = {
[path] = /opt/games/tome-159//game/engines/te4-1.5.9.tea

I don't think there should be a second / between tome-159 and game

Also in checking directory structure I noticed owner was set for ftp and group to users, not the normal in our world where we run in a single level and where we all run as root.
I shall change a copy and see what happens and report back later today when I have some time to spare.

After all it's mothers day here.

PostPosted: Sun May 13, 2018 12:37 am 

Joined: Sat May 12, 2018 5:43 am
Posts: 45
OK, she's late so I have had a go.

installed xdg-utils to add xdg-mime

stared it again at the save spot

tried again to change level up to the world map and it 'stuck'

quit the game

looked through the lines and found

Loading entities file from file /data/zones/wilderness/traps.lua which does not exist!

everything else seems ok


EDIT1: strange, when I started it again after the kill and loaded the savegame, it took me on to the next level.
Tried it going to level 2 instead of the world and it's done the same thing.
?There wouldn't have been a pause or stop point left in there somewhere?
It's also doing the same thing when i've been killed.

PostPosted: Mon May 14, 2018 3:35 am 

Joined: Sat May 12, 2018 5:43 am
Posts: 45
Sorry for the delay, but i've been having a few goes with different characters and the like as I thought I should have a good look at it for you.

the problem seems to be when:
saving to exit
saving to go to the menu
changing levels the first few times

and i'm offline (no web access on thie games machine)
and it's starting as t-engine --no-web
not sure where it's getting the --no-web, but it's right.

In ALL cases as the last few lines i seem to be getting
[PROFILE] Thread connecting to on ports 2257 2258

before I have a killed message

hope this helps as i'm intersted in this rpg game, but only if it works of course.

PostPosted: Sat May 19, 2018 4:35 am 

Joined: Sat May 12, 2018 5:43 am
Posts: 45
apologies for spelling errors and the like, i've been given a new keybaord
(it's one of those curved ones) as my old one was failing and she thought
it was time, I will get an equivalent flat one as soon as I can

Some Problems found:


Video Options/
If set to Windowed mode the mouse cursor becomes out of actual row position by one line
> means you can't swap back to the screen to see any console messages unless you exit or kill the game
> also means you can't be sure your in the right spot while playing it.

Video Options/
> turning these as well as framebuffers to disabled seriously makes the game run better if using internal video

Game Options/
Upload Character Sheets to the Online Vault/
> seems to reset itself to enabled when it feels like it
> especially if the game "BOMBS"

~at random times when starting, but not actually started a game yet (sitting at a level below Main Menu)>
> it starts a large box lableled "Generating level 'Please wait while generating the level...'"
> it stays like this until you kill it>> (I once left it for 4 hours before I killed it).
> Console's last line after a kill was "Creating level dungeon " <<no level number

~ your black screen of death is still there>
I could get it if>
I was killed, went to the "Re-animator level" (not sure the real name but you get the idea),
Asked to return to where I was and was killed again,
was returned to the start of the game,
exited to the Menu,
reloaded the save game.
>didn't get it every time, but enough to be annoying
>console gave no message about loading me or anything else as it was gone
>almost as if it was itself killed when I killed the ToME process

~ when changing levels or trying to save or look at my stats, etc.,. it locks up>
> noticed a large box said it was doing the function
>BUT there was no 'action bar' appearing with a strip sliding to the right to showing it was happening
> on a kill it seemed on the console that it was doing the screen change and was waiting for something to happen
>eg changeing a level from trollmine 1 to 2 the console returned>>
[COROUTINE] registering savepipefile thread: 0x42517940
Loading level persistance level trollmire 2
Killed <<from my kill routine, nothing else shown

Only save that consistantly worked more than 90% was save to Menu,
Others more often failed than processed through
Trollmire seems to have it the worst though
>got a "saving game" in bottom corner about half the time
>but rarely the following "saved game"
Console usually gave me>>
[LOG] Saving game....
[SAVEFILE PIPE] force waiting
Killed <<from my kill routine, nothing else shown
> and that setup>game options>upload... has reset itself as enabled again when you go in and check
>another interesting thing is that it gets less common to fail as you are get up to a higher level

more later (if you want it)

PostPosted: Fri Jun 08, 2018 1:13 am 

Joined: Sat May 12, 2018 5:43 am
Posts: 45
OK, with a lot of re-starting and playing about I have at least workarounds if not fixed most of my problems.
It works at least for me;
Firstly, when you've picked your character and saved your "starting character points", BUT, before you have any action (if you can) do an ordinary save;
make your first kill/pickup and do a save to menu;
from here on most of my problems have dissapeared;
other than lockups and segmentation faults.
I suspect they maybe related to missing files or settings that are created when save files are first created.

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 

All times are UTC

Who is online

Users browsing this forum: No registered users and 1 guest

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group