ToME: the Tales of Maj'Eyal
http://forums.te4.org/

Compiling From Source--Luajit failing?
http://forums.te4.org/viewtopic.php?f=44&t=48737
Page 1 of 1

Author:  alex_hall [ Sat Mar 17, 2018 7:18 am ]
Post subject:  Compiling From Source--Luajit failing?

Hey Folks,

I participated in this year's 7drl using the Godot engine. I had fun, but I feel like the engine is getting in my way as much as helping me. I want to give t-engine4 a try, because it looks to have all of the features I want in an engine. Unfortunately, I have been unable to compile from source on archlinux. I asked for help in IRC and Discord, but nobody was able to help me.

I can successfully run everything up to and including
Code:
premake4 gmake
. When I run
Code:
make
it gets to
Code:
Linking TEngine
then throws about a hundred
Code:
undefined reference to lua*
errors.

I've tried installing luajit on my pc, but no luck there. I've tried the master branch from git and the 1.5 branch. I've tried the zip file available in the Downloads section of te4.org. So far, nothing.

Any thoughts on how to fix this? I'd really like to be able to use this engine, but if I can't compile it, then I will have a hard time making changes to the engine internals if that ever becomes necessary.

I've attached the errors as a .txt file in case that's helpful.

Attachments:
install_results.txt [58.73 KiB]
Downloaded 112 times

Page 1 of 1 All times are UTC
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/