ToME: the Tales of Maj'Eyal
http://forums.te4.org/

Crashes if logged in
http://forums.te4.org/viewtopic.php?f=44&t=42808
Page 1 of 1

Author:  grayswandir [ Mon Nov 10, 2014 9:01 pm ]
Post subject:  Crashes if logged in

As of yesterday, if I'm logged in and try to start/load a game, it crashes in the load screen. This doesn't happen if I'm not logged in. I tried with 1.2.4, 1.2.5, and master. I also tried deleting my 'online' profile folder.
Code:
Computing fun facts
true
[1] = Total playtime of all registered players:
465 years, 287 days, 14 hours and 5 minutes
Lua Error: attempt to call a nil value
   At [C]:-1
   At /engine/utils.lua:91 print
   At /engine/Module.lua:625 selectFunFact
   At /engine/Module.lua:703
   At [C]:-1 enable
   At /engine/Module.lua:633 loadScreen
   At /engine/Module.lua:853 instanciate
   At /engine/utils.lua:2235 showMainMenu
   At /engine/init.lua:156
   At [C]:-1 dofile
   At /loader/init.lua:196
PANIC: unprotected error in call to Lua API (attempt to call a nil value)

I can't make any sense of the error message. It seems to jump around, as well - it'll occasionally be on a different line.

Author:  stinkstink [ Mon Nov 10, 2014 11:06 pm ]
Post subject:  Re: Crashes if logged in

I got that a few days ago but figured it was a weird Steam hiccup as I was having trouble logging in there as well. I went to bed and both ToME and Steam were working when I woke up.

Page 1 of 1 All times are UTC
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/