ToME: the Tales of Maj'Eyal
http://forums.te4.org/

ToMe Not Saving
http://forums.te4.org/viewtopic.php?f=42&t=49568
Page 1 of 1

Author:  Raenarill [ Sun May 26, 2019 5:34 pm ]
Post subject:  ToMe Not Saving

Hey everyone,

I've been playing ToMe for a long time now, over 1000 hours clocked on Steam, and I'm quite sad that the game isn't working anymore. I tried googling around to see if there was an answer to my issue, but I found nothing, so I'm it posting here. The game won't save anymore, the save bar reaches 100%, and then keeps going, I've sat there and waited until it hit 13000% before. I cannot close the game while it does this, I have to end the process through Windows task manager.

Things I've done already:
- Disabled (and then removed) all addons
- Reinstalled ToMe.
- Removed all of my past saves/settings/local files from C:Users\T-Engine
- Went into administrator mode command line and manually removed read-only attribute from all ToMe files/folders.

As of this writing nothing has worked, I've attached the ToMe log file as well, if I had to hazard a guess it's probably this part that's breaking it:
Code:
Loading savefile    /save/bob/
[SAVEFILE PIPE] Resaving sent   Bob   entity   /vault/Bob/character.teac.tmp
Saving zipname /vault/Bob/character.teac.tmp
Saved zipname /vault/Bob/character.teac.tmp
[SAVEFILE PIPE] Checking save   Bob   entity   /vault/Bob/character.teac.tmp
Loading savefile    /save/bob/
[SAVEFILE] checked validity of type   entity    => path not found
[SAVEFILE] path info   /vault/Bob/character.teac   =>   nil
[SAVEFILE PIPE] *RE*new save running in the pipe:   Bob   entity   ::   character.teac   ::   table: 0x16c02dc8   =>   table: 0x1850f658


Since that repeats over and over and is the last thing in the log file, and looks to be the saving process.

Apologies if this error has occurred before and has already been resolved, but I appreciate any and all help here!

Thanks,

Rae

Log File: https://privatebin.net/?3f3344a9c809d30 ... g+KpJnjJI=

Author:  BugReporter [ Mon Jun 03, 2019 7:47 pm ]
Post subject:  Re: ToMe Not Saving

I'm not really sure what to suggest here. Maybe you can try another directory for user files:
1. Create a directory (example, C:\tmp\).
2. Go to the directory where t-engine.exe is located (example, C:\games\t-engine4\).
3. Right click on t-engine.exe and create a shortcut.
4. Right click on the shortcut and select properties.
5. Add after t-engine.exe
Code:
 --home C:\tmp

example
Code:
C:\Games\T-Engine4\t-engine.exe --home C:\tmp

6. Start the game from that shortcut.

Quote:
Removed all of my past saves/settings/local files from C:Users\T-Engine
Were directories created in C:/users/YourUsername/ after you started the game? Were directories empty after you tried to save?

Author:  HousePet [ Tue Jun 04, 2019 3:25 am ]
Post subject:  Re: ToMe Not Saving

I suspect BugReporter is on the right track here. Something changed in Windows recently that upset whether ToME could read/write correctly to its home directory in the Users folder.

I suggest uninstalling ToME and then wiping its home directory in the Users folder. Or you could try redirecting it to a new one while running in Admin Mode, first.

Author:  BugReporter [ Mon Jun 10, 2019 6:38 pm ]
Post subject:  Re: ToMe Not Saving

I vaguely remember about an issue Win 10 OneDrive. It was interfering with saves from a different game. If i remember correctly that game used Documents directory. I can't find the topic anymore. Maybe it is worth a try.

Author:  Raenarill [ Thu Jul 04, 2019 10:01 pm ]
Post subject:  Re: ToMe Not Saving

Hey guys,

Just wanted to give an update regarding the issue. Strangely enough, it was actually when I was using another program that I discovered the issue. For some reason, Windows stopped granting programs the ability to write to my C drive at all, and thus ToMe was not allowed to create a save file on my C drive.

Just in case anyone else ever has this problem and needs a solution, simply running ToMe as administrator fixed the problem!

Thanks again for all the help guys,

Rae

Page 1 of 1 All times are UTC
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/