ToME: the Tales of Maj'Eyal

Everything about ToME
It is currently Thu Nov 21, 2019 5:13 am

All times are UTC




Post new topic Reply to topic  [ 4 posts ] 
Author Message
PostPosted: Sat Feb 16, 2019 2:10 pm 
Offline
Low Yeek

Joined: Sat Feb 16, 2019 2:02 pm
Posts: 7
As it stands, Possessor early game plays fine and without any major issues. However, as the game progresses, bodies accumulate in storage, and enemies are copied via Psychic Crush, performance quickly deteriorates. This results in extreme lag spikes lasting upwards of five seconds, out-of-memory violations, the inability to save, and the subsequent crash and deletion of the player's save upon the (attempted) changing of zones. This issue has occurred consistently across my Possessor playthroughs, typically ending them soon after reaching level ten.


Top
 Profile  
 
PostPosted: Sat Feb 23, 2019 3:29 am 
Offline
Low Yeek

Joined: Sat Feb 16, 2019 2:02 pm
Posts: 7
Decided to upload a log and some reproduction steps for the sake of debugging.

The errors and getting stuck/crashing upon changing zones has happened in 100% of my playthroughs. Steps for repeating are as thus:

1. Play Possessor
2. To accelerate effects, use Psychic Crush often, as Possessor does anyways.
3. Eventually, large lag spikes will begin to occur when copying enemies with Psychic Crush, or when Possessing them.
4. Soon after the lag spikes begin, you will get an error similar to this one.
5. Your save is now doomed. The game will continue to spill out memory errors, you may not save, and you will become eternally stuck when attempting to exit the zone.

I have attached a log of a recently doomed playthrough, however useful this may be. Hoping a fix is found.

edit: I lied, I had to upload the log to a Google Doc.

edit 2: Testing has confirmed this issue is isolated to 1.6. (On my end, at least.)

edit 3: Issue is occurring for some users on 1.5 as well. Issue seems to be isolated to Psychic Crush.


Last edited by Mango kangaroo on Fri Apr 12, 2019 12:11 am, edited 2 times in total.

Top
 Profile  
 
PostPosted: Mon Feb 25, 2019 12:59 am 
Offline
Low Yeek

Joined: Sat Feb 16, 2019 2:02 pm
Posts: 7
After additional testing, I can confirm this issue is isolated to 1.6. I have had no issues with Possessor performance in 1.5 using the same playstyle.


Top
 Profile  
 
PostPosted: Fri Apr 12, 2019 12:10 am 
Offline
Low Yeek

Joined: Sat Feb 16, 2019 2:02 pm
Posts: 7
Bumping as I've gotten reports that this is happening in 1.5 as well. I get a lot of performance issues with Possessor in 1.5, but have not gotten the crashes and save deletions I see in 1.6. The person noted the issues (Lag, LUA errors) happening when using Psychic Crush, so that's looking like the culprit.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 7 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group