ToME: the Tales of Maj'Eyal
http://forums.te4.org/

(1.6) Possessor Memory Leak Results in Lag and Deleted Save
http://forums.te4.org/viewtopic.php?f=42&t=49421
Page 1 of 1

Author:  Mango kangaroo [ Sat Feb 16, 2019 2:10 pm ]
Post subject:  (1.6) Possessor Memory Leak Results in Lag and Deleted Save

As it stands, Possessor early game plays fine and without any major issues. However, as the game progresses, bodies accumulate in storage, and enemies are copied via Psychic Crush, performance quickly deteriorates. This results in extreme lag spikes lasting upwards of five seconds, out-of-memory violations, the inability to save, and the subsequent crash and deletion of the player's save upon the (attempted) changing of zones. This issue has occurred consistently across my Possessor playthroughs, typically ending them soon after reaching level ten.

Author:  Mango kangaroo [ Sat Feb 23, 2019 3:29 am ]
Post subject:  Re: (1.6) Possessor Memory Leak Results in Lag and Deleted S

Decided to upload a log and some reproduction steps for the sake of debugging.

The errors and getting stuck/crashing upon changing zones has happened in 100% of my playthroughs. Steps for repeating are as thus:

1. Play Possessor
2. To accelerate effects, use Psychic Crush often, as Possessor does anyways.
3. Eventually, large lag spikes will begin to occur when copying enemies with Psychic Crush, or when Possessing them.
4. Soon after the lag spikes begin, you will get an error similar to this one.
5. Your save is now doomed. The game will continue to spill out memory errors, you may not save, and you will become eternally stuck when attempting to exit the zone.

I have attached a log of a recently doomed playthrough, however useful this may be. Hoping a fix is found.

edit: I lied, I had to upload the log to a Google Doc.

edit 2: Testing has confirmed this issue is isolated to 1.6. (On my end, at least.)

edit 3: Issue is occurring for some users on 1.5 as well. Issue seems to be isolated to Psychic Crush.

Author:  Mango kangaroo [ Mon Feb 25, 2019 12:59 am ]
Post subject:  Re: (1.6) Possessor Memory Leak Results in Lag and Deleted S

After additional testing, I can confirm this issue is isolated to 1.6. I have had no issues with Possessor performance in 1.5 using the same playstyle.

Author:  Mango kangaroo [ Fri Apr 12, 2019 12:10 am ]
Post subject:  Re: (1.6) Possessor Memory Leak Results in Lag and Deleted S

Bumping as I've gotten reports that this is happening in 1.5 as well. I get a lot of performance issues with Possessor in 1.5, but have not gotten the crashes and save deletions I see in 1.6. The person noted the issues (Lag, LUA errors) happening when using Psychic Crush, so that's looking like the culprit.

Author:  lifanov [ Thu Dec 12, 2019 2:31 pm ]
Post subject:  Re: (1.6) Possessor Memory Leak Results in Lag and Deleted S

I can reproduce this with 1.6.4.
I have a yeek possessor that can't get past ritch tunnels.
The error is triggered as soon as I try to possess the boss there.
I have used Psychic Crush.

Author:  Snarvid [ Thu Dec 12, 2019 7:01 pm ]
Post subject:  Re: (1.6) Possessor Memory Leak Results in Lag and Deleted S

This was supposedly fixed...?

viewtopic.php?f=42&t=50097&hilit=possessor+bug

Author:  Mango kangaroo [ Thu Dec 12, 2019 7:05 pm ]
Post subject:  Re: (1.6) Possessor Memory Leak Results in Lag and Deleted S

DarkGod fixed a lot of the issues both in 1.6 and in the patches after afaik. I personally have had no issues with lag following the 1.6 release, and my complaints are for all intents and purposes resolved.

If other people are having issues, I believe it might warrant a new bug report as opposed to trying to revive this one.

Page 1 of 1 All times are UTC
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/