ToME: the Tales of Maj'Eyal

Everything about ToME
It is currently Thu Sep 19, 2019 12:54 am

All times are UTC




Post new topic Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Wed Feb 13, 2019 1:34 am 
Offline
Yeek

Joined: Wed Dec 23, 2015 12:51 am
Posts: 13
I have been getting disconnected from the server with alarming frequency on this character, and only this character: https://te4.org/characters/149541/tome/ ... 4a4a2bb027 . Like, disconnected multiple times per minute while in combat. And once the game gets to that state, saving the game will also disconnect until the save is done every time--effectively never updating the online character sheet. Also, achievements don't get sent to chat, though I don't really care about that part.

I have isolated a way to be able to save without getting disconnected though, and that is to deactivate Furnace beforehand. However, keeping Furnace off does not stop repeated disconnects. Also, deactivating Furnace will cause a disconnect usually.

And no, I have not gotten any LUA error popup on this character yet. And this has been happening long before I got the bunnificated and badassery things.


In the attached log, ran with `--flush-stdout`, I...
1. load the game
2. activate Furnace
3. kill an enemy
4. see that I got disconnected
5. wait to reconnect to save... 3 times in a row, each time getting disconnected
6. deactivate furnace
7. save again, this time free of disconnect
8. exit game


Attachments:
20120912_1_te4_log.zip [76.49 KiB]
Downloaded 18 times
Top
 Profile  
 
PostPosted: Wed Feb 13, 2019 7:30 pm 
Offline
Yeek

Joined: Wed Dec 23, 2015 12:51 am
Posts: 13
I believe I have found a key component of this bug: Heartrend, the unique steamsaw. I was able to clear an entire level, and the game saved fine, without a single disconnect when I did not have it equipped. As soon as I equipped it again and started mowing stuff down, the disconnects started happening as before, and I had to deactivate Furnace to be able to save without a disconnect.


Top
 Profile  
 
PostPosted: Fri Feb 15, 2019 8:18 pm 
Offline
Yeek

Joined: Wed Dec 23, 2015 12:51 am
Posts: 13
This bug is easily reproducible with the same build on new characters and the unique steamsaw, Heartrend. However, it has been pretty laborious for me to try to pinpoint what exactly triggers it in dev mode, since Heartrend isn't spawnable via the dev menu and doesn't spawn when the spawn all artifacts option is chosen either. It definitely does happen in dev mode, but I've kind of given up figuring it out since I have to startscum Kaltor's shop in hopes he has Heartrend since I don't know how to spawn it via the console.

Attached is screenshots of the disconnect spam to illustrate what is going on, and puts a picture to the exact steps I did in the first post to make the log I posted there.


Attachments:
20190215_tome4_disconnect_spam_game_log.jpg
20190215_tome4_disconnect_spam_game_log.jpg [ 133 KiB | Viewed 274 times ]
20190215_tome4_disconnect_spam_chat_log.jpg
20190215_tome4_disconnect_spam_chat_log.jpg [ 36.51 KiB | Viewed 274 times ]
Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 6 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group