ToME: the Tales of Maj'Eyal
http://forums.te4.org/

My force field is stuck
http://forums.te4.org/viewtopic.php?f=42&t=48496
Page 1 of 1

Author:  elfmaster [ Wed Dec 27, 2017 12:54 am ]
Post subject:  My force field is stuck

So i was adventuring on Christmas Eve with Neutronium, my Insane Mindslayer (new holiday tradition?) when suddenly I was gifted with a festive present! Not a mere sword or cloak, but no less than a free prodigy point!! I shouted praise to Our Benevolent and Most Wholey Darkgod, He Who Sees All and Giveth and Taketh Life. But prodigies cannot be activated until level 30, so in the meantime I set off to visit my friend Urkis to help share my festive spirit via double greatswords.

But then during a battle I noticed some weird behavior with my anti-magic. An opponent hit me about 75 times for 1 point damage, and my anti-magic responded with about 75 strikes of 12 damage each. Alrighty then... I didn't complain about the 1000 points free damage, but... a couple rounds later I activated my Force Field, which promptly threw a LUA error. Not sure if the two incidents are related. For the rest of the battle, anytime I activated an ability I received another error. I still managed to win the fight by bumping my opponent to death, but that's when I realized something was wrong. It appears my force field is now permanently half-stuck to the ON position. I'm not sure if it still is providing any protective benefit, but my Psi score is now permanently stuck at about 30 when it used to be about 85 (after running all my sustains). The yellow force field aura graphic is also stuck on. Turns out having a permanently gimped Psi score is bad for my survival.

Is there perhaps a dev that can fix my Mindslayer save file? I'd be sad if I had to abandon him and not get to claim my present.

Author:  nuhb [ Tue Jan 16, 2018 2:37 pm ]
Post subject:  Re: My force field is stuck

Bump, same thing happened to me, lua error when activating forcefield while I was standing in an aoe fire spell of a rare fire wyrm. Forcefield didnt activate, but the shader for the bubble did and the 30 psi drain for the sustain. Now stuck with the permanent psi drain as well as the shader, persists after restart, I can basically put that character in the trash can.

Sadly I cant find that error in the log anymore, I only found another error the wyrm caused when casting lightning:

Code:
[LOG]   Velebreba the fire wyrm casts Lightning.
[SPELL CRIT %]   18.5
##Use Talent Lua Error##   T_LIGHTNING   Actor:   4612   Velebreba the fire wyrm
Lua Error: /engine/interface/ActorTalents.lua:322: /engine/interface/ActorTalents.lua:295: /engine/interface/ActorTalents.lua:162: /data/damage_types.lua:477: attempt to index local 'ret' (a number value)
stack traceback:
   /data/damage_types.lua:477: in function 'defaultProjector'
   /data/damage_types.lua:775: in function 'projector'
   /data/damage_types.lua:1482: in function 'projector'
   /engine/interface/ActorProject.lua:219: in function 'project'
   /data/talents/spells/air.lua:43: in function </data/talents/spells/air.lua:38>
   [C]: in function 'xpcall'
   /engine/interface/ActorTalents.lua:160: in function </engine/interface/ActorTalents.lua:149>
   At [C]:-1
   At [C]:-1 error
   At /engine/interface/ActorTalents.lua:322 useTalent
   At /mod/ai//tactical.lua:418 runAI
   At /mod/ai//tactical.lua:446 doAI
   At /mod/class/NPC.lua:75 act
   At /engine/GameEnergyBased.lua:129 tickLevel
   At /engine/GameEnergyBased.lua:64 tick
   At /engine/GameTurnBased.lua:51 tick
   At /mod/class/Game.lua:1386
 ----------------  Stack Dump ----------------
--------------- Stack Dump Finished ---------------


I could however load up the character if that would help, only need to know which files are the actual save files.

Page 1 of 1 All times are UTC
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/