ToME: the Tales of Maj'Eyal

Everything about ToME
It is currently Mon Aug 19, 2019 11:56 am

All times are UTC




Post new topic Reply to topic  [ 1 post ] 
Author Message
PostPosted: Sun Jun 23, 2019 3:47 pm 
Offline
Yeek

Joined: Sun Jun 23, 2019 3:25 pm
Posts: 13
I would like to use T-Engine4 to develop a roguelike but I'm having a lot of trouble figuring some things out. To start with, I wanted to modify the simple example project to use a tileset rather than ascii for the random dungeon that it generates. Simple right? No. For for the life of me I can't get it to work.

I put my tile images in a 'terrain' directory under the gfx folder. In the general/grids/basic.lua file I pointed the walls and floors to my tileset images (name = "wall", image = "terrain/granite_wall1.png", for example). However, no matter what I do, it still loads up showing ascii instead of the tiles. Tilesets are enabled in my game options so I can't figure out why it doesn't use my tile images.

After 2 days of trying to figure this out, I'm beyond frustrated. Nowhere in the sparse documentation does it mention tilesets at all. There are no examples. I looked at the Hulk module and as far as I can tell, I'm doing what they did but it still doesn't work.

Can someone please tell me what I'm doing wrong or what i need to do to get tilesets to be used in modules?


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group