ToME: the Tales of Maj'Eyal

Everything about ToME
It is currently Sat Dec 07, 2019 9:49 pm

All times are UTC




Post new topic Reply to topic  [ 6 posts ] 
Author Message
PostPosted: Wed Oct 02, 2019 2:55 pm 
Offline

Joined: Wed Oct 02, 2019 2:01 pm
Posts: 3
Updating to the new library beta on Linux causes both Steam and ToME4 to mutually break each other. The game window goes entirely white and sometimes (though not every time) the Steam Library itself becomes unresponsive until restarting the entire Steam client. The game functions perfectly fine once you revert back to the non-beta client. This happens on both the 1.6 beta and current 1.5 patch, but the logs attached are from 1.5.

The logging command for Linux in the stickied post doesn't appear to work, but I pulled some logs after launching Steam through the terminal for both the working and broken version, hopefully they'll suffice.

Screenshots: https://imgur.com/a/89Y3HTk


Attachments:
File comment: ToME 4 logs - working on the old library.
tome4-working(old).txt [105.98 KiB]
Downloaded 10 times
File comment: ToME 4 logs - broken on the new library beta.
tome4-broken(new).txt [114.5 KiB]
Downloaded 11 times
Top
 Profile  
 
PostPosted: Thu Oct 03, 2019 2:56 pm 
Offline
Master of Eyal

Joined: Wed Jul 24, 2002 9:26 pm
Posts: 10438
Location: Angolwen
Ugh .... and can you try the beta client with overlay disabled? I'd assume it works too ?

_________________
[tome] joylove: You can't just release an expansion like one would release a Kraken XD
--
[tome] phantomfrettchen: your ability not to tease anyone is simply stunning ;)


Top
 Profile  
 
PostPosted: Fri Oct 04, 2019 4:11 pm 
Offline

Joined: Wed Oct 02, 2019 2:01 pm
Posts: 3
Didn't even occur to me to try that; yep, it works perfectly with the overlay disabled. I rarely even use the overlay, so that'll suffice as a workaround for now.


Top
 Profile  
 
PostPosted: Sat Oct 05, 2019 11:40 pm 
Offline
Wayist

Joined: Wed Mar 05, 2014 1:38 am
Posts: 25
Disabling the overlay doesn't fix the problem for me. I get the white screen every time when launching through Steam.


Top
 Profile  
 
PostPosted: Wed Oct 09, 2019 9:20 am 
Offline
Master of Eyal

Joined: Wed Jul 24, 2002 9:26 pm
Posts: 10438
Location: Angolwen
should be fixed in beta2

_________________
[tome] joylove: You can't just release an expansion like one would release a Kraken XD
--
[tome] phantomfrettchen: your ability not to tease anyone is simply stunning ;)


Top
 Profile  
 
PostPosted: Wed Oct 09, 2019 7:22 pm 
Offline

Joined: Wed Oct 02, 2019 2:01 pm
Posts: 3
Yep, works perfectly now. Thank you!


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC


Who is online

Users browsing this forum: Bing [Bot] and 7 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group