ToME: the Tales of Maj'Eyal

Everything about ToME
It is currently Sun Jun 24, 2018 10:53 am

All times are UTC




Post new topic Reply to topic  [ 86 posts ]  Go to page Previous  1, 2, 3, 4, 5, 6
Author Message
PostPosted: Sun Aug 20, 2017 3:12 am 
Offline

Joined: Sun Aug 20, 2017 3:02 am
Posts: 2
As Posessor, it's possible to get a bug where the game rests infinitely for mana while you have 0 regen.

Repro steps:
1. Start up a game as a posessor.
2. Acquire a mana-using talent from an escort or through the Lua Console with e.g.
Code:
game.player:learnTalent(game.player.T_PHASE_DOOR, true, 1)

3. At this point, no regen is displayed in the mana bar and resting still works normally even if you are missing mana.
4. Assume a form with some base mana regen (All your starting corpses have this, and maybe all monsters do? Not sure. )
5. Return to your normal form. Now, instead of not displaying regen, your mana bar shows your regen as "0.00".
6. Spend some mana and then attempt to rest.
7. The game will now wait forever for your mana to regenerate, even though it will never do so.

I can do the same thing with this addon disabled, and resting will still work and not wait for mana.


Top
 Profile  
 
PostPosted: Thu Jan 18, 2018 9:26 pm 
Offline
Cornac

Joined: Tue Apr 09, 2013 10:54 am
Posts: 31
Always Vigilant isn't stopping me for telepathy in any capacity. I'm using tome 1.5.5, addon version 3.3.11 and wearing a telepathy:all cloak.


Top
 Profile  
 
PostPosted: Sat Feb 24, 2018 7:44 am 
Offline
Archmage

Joined: Sun Jul 13, 2014 4:09 pm
Posts: 367
It's kinda been a while since I've actively been playing this, so sorry folks haven't really been keeping up with the fixes. :(

Might try some tomorrow after taxes.

_________________
ToME Tips - auto-generated spoilers for ToME. - someone else made. I find super awesome, so spreading as well.


Top
 Profile  
 
PostPosted: Sat Feb 24, 2018 11:24 pm 
Offline
Archmage

Joined: Sun Jul 13, 2014 4:09 pm
Posts: 367
@nottheinferno

Long time coming but good repro. Went ahead, repro'd and have fix locally. Cause really is that becomes a ridiculous non-zero value. Not sure how it doesn't cause problems anywhere but it's kinda unsafe. Put a sanity check for things being less than .0001

_________________
ToME Tips - auto-generated spoilers for ToME. - someone else made. I find super awesome, so spreading as well.


Top
 Profile  
 
PostPosted: Sun Feb 25, 2018 1:17 am 
Offline
Archmage

Joined: Sun Jul 13, 2014 4:09 pm
Posts: 367
cybaster wrote:
Always Vigilant isn't stopping me for telepathy in any capacity. I'm using tome 1.5.5, addon version 3.3.11 and wearing a telepathy:all cloak.



Looks like that got broken sometime around one of the 1.3/1.4 merges.

Okay bringing it back.

_________________
ToME Tips - auto-generated spoilers for ToME. - someone else made. I find super awesome, so spreading as well.


Top
 Profile  
 
PostPosted: Sun Feb 25, 2018 1:48 am 
Offline
Archmage

Joined: Sun Jul 13, 2014 4:09 pm
Posts: 367
Okay, updated. Both of those fixed. Thanks for reporting.

_________________
ToME Tips - auto-generated spoilers for ToME. - someone else made. I find super awesome, so spreading as well.


Top
 Profile  
 
PostPosted: Sun Feb 25, 2018 5:14 pm 
Offline
Cornac

Joined: Tue Apr 09, 2013 10:54 am
Posts: 31
Works for me now. Thank you!


Top
 Profile  
 
PostPosted: Thu Mar 01, 2018 5:59 am 
Offline
Archmage

Joined: Sun Jul 13, 2014 4:09 pm
Posts: 367
A quick set of bug fixes for the side effects of reviving that code :)

_________________
ToME Tips - auto-generated spoilers for ToME. - someone else made. I find super awesome, so spreading as well.


Top
 Profile  
 
PostPosted: Sun Mar 18, 2018 5:46 am 
Offline
Archmage

Joined: Sun Jul 13, 2014 4:09 pm
Posts: 367
So there's a bug in the current version with First Seen. I've partially got it fixed. Haven't had much time but please just use Original or Vigilant for now.

_________________
ToME Tips - auto-generated spoilers for ToME. - someone else made. I find super awesome, so spreading as well.


Top
 Profile  
 
PostPosted: Wed Apr 25, 2018 3:43 am 
Offline
Archmage

Joined: Sun Jul 13, 2014 4:09 pm
Posts: 367
Huh, just my luck.

Anyhow, I've been busy/sick and not having much luck with lua syntax for adding a circular buffer to fix the problem.

Uploaded a version commenting out the broken parts so it won't crash for now.

_________________
ToME Tips - auto-generated spoilers for ToME. - someone else made. I find super awesome, so spreading as well.


Top
 Profile  
 
PostPosted: Sun Jun 10, 2018 4:07 am 
Offline
Cornac

Joined: Tue Apr 09, 2013 10:54 am
Posts: 31
Get well soon, buddy!

Also, the latest version appears to have no configuration menu. I can't find any settings anywhere to configure how it behaves.

Huh. It appears to be working fine, now. I'm not sure what was causing the problem on my end.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 86 posts ]  Go to page Previous  1, 2, 3, 4, 5, 6

All times are UTC


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group