[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4752: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3887)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4754: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3887)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4755: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3887)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4756: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3887)
ToME: the Tales of Maj'Eyal • View topic - Slow load/save/turns

ToME: the Tales of Maj'Eyal

Everything about ToME
It is currently Wed Apr 21, 2021 1:22 am

All times are UTC




Post new topic Reply to topic  [ 17 posts ]  Go to page 1, 2  Next
Author Message
 Post subject: Slow load/save/turns
PostPosted: Sat Nov 07, 2020 12:25 am 
Offline
Low Yeek

Joined: Sat Nov 07, 2020 12:13 am
Posts: 6
Hi all,

I've been playing this wonderful game for a while now and I'm a bit stumped as far as how to fix this problem. I had the game running fine a few hours ago and then when I booted it back up it takes between 30 seconds to 2 minutes to load the menus, new character creation, saved files, you name it. The turns also take a while, they used to be nearly instantaneous and now take about 5-20 seconds per turn depending on the number of characters on the map. Here's the weird thing, the turns are nice and fast as long as ToME is NOT the active window. So to finish up a combat I just kept minimizing the game to speed up the turns.

I've tried reinstalling the game to my SSD, looking through the te4_log.txt file with no luck for any lua related errors and messing with resolution settings. I've also done some Google searches to see if others were having similar issues but couldn't find any good fixes as well. Let me know if I can provide any more info as well.

Thoughts?


Top
 Profile  
 
 Post subject: Re: Slow load/save/turns
PostPosted: Sat Nov 07, 2020 10:03 pm 
Offline
Archmage

Joined: Sun Jul 13, 2014 4:09 pm
Posts: 405
Unsure but I may be seeing the same thing. It's just aaagh slow with only official game addons.

Most of it's being in load/save bars, and appearing to be in it's own usage (1-15 percent slow as hell, then poof done) but just wandering maps is unplayably slow and unresponsive right at the beginning. I'm about to investigate further.

_________________
- auto-generated spoilers for ToME. - someone else made. I find super awesome, so spreading as well.


Top
 Profile  
 
 Post subject: Re: Slow load/save/turns
PostPosted: Sat Nov 07, 2020 10:33 pm 
Offline
Archmage

Joined: Sun Jul 13, 2014 4:09 pm
Posts: 405
Another restart seems to have fixed it, and it got into that state after being in debug mode. Fingers crossed it stays fixed.

_________________
- auto-generated spoilers for ToME. - someone else made. I find super awesome, so spreading as well.


Top
 Profile  
 
 Post subject: Re: Slow load/save/turns
PostPosted: Sun Nov 08, 2020 2:30 am 
Offline
Low Yeek

Joined: Sat Nov 07, 2020 12:13 am
Posts: 6
I didn't even know there was a debug mode. I found something else to add to my original post. Changing the FPS from 60 down to 30 seemed to help a little for the turns to speed up, the saving and loading times are still very long though.


Top
 Profile  
 
 Post subject: Re: Slow load/save/turns
PostPosted: Sun Nov 08, 2020 3:29 pm 
Offline
Archmage

Joined: Sun Jul 13, 2014 4:09 pm
Posts: 405
Definitely going in and out of it. Played for 10-ish hours yesterday no problem. Started up today and saves/loads/steps are entirely unplayable slow. Rebooting it again.

Nothing clear going on in the logs during the save. PC is a powerhouse, and is mostly unburdened at the moment in every task manager view.

This is definitely a real thing but unsure how to give DarkGod anything to go on here. The logs look clean and it's not 'every' time, maybe it's some game cache getting into a bad state?

Restarted the app, changing nothing else on the machine, and turns went from taking 7-8 seconds to basically instant. Same everything.
--

From the bugs chat, at least 2 people hitting it have Nvidia.

It seems unlikely to be a graphics things because of the save/load to me?

_________________
- auto-generated spoilers for ToME. - someone else made. I find super awesome, so spreading as well.


Top
 Profile  
 
 Post subject: Re: Slow load/save/turns
PostPosted: Sun Nov 08, 2020 11:45 pm 
Offline
Thalore

Joined: Thu Sep 26, 2019 4:32 pm
Posts: 147
Hey, all y'all who're facing these severe slowdowns:

Please go download version 1.7.0 (https://te4.org/download) and use the .exe and & dlls from THAT version on your 1.7.2 installation.

If that fixes the slowdowns "permanently", then please report back here with your GPU/CPU


Top
 Profile  
 
 Post subject: Re: Slow load/save/turns
PostPosted: Mon Nov 09, 2020 12:39 am 
Offline
Low Yeek

Joined: Sat Nov 07, 2020 12:13 am
Posts: 6
Thanks for addressing this Moasseman. Just a quick question for clarification if you don't mind. After downloading the files that you specified, are you instructing me to copy over the original files in the Steam directory?


Top
 Profile  
 
 Post subject: Re: Slow load/save/turns
PostPosted: Mon Nov 09, 2020 1:14 am 
Offline
Thalore

Joined: Thu Sep 26, 2019 4:32 pm
Posts: 147


Top
 Profile  
 
 Post subject: Re: Slow load/save/turns
PostPosted: Mon Nov 09, 2020 3:08 am 
Offline
Low Yeek

Joined: Sat Nov 07, 2020 12:13 am
Posts: 6
Tried what you mentioned as the slowdowns are indeed gone! Thanks so much for the suggestion. I am getting some weird graphical things now, like there's weird black and white squares around my character, but the game seems back to normal otherwise.


Top
 Profile  
 
 Post subject: Re: Slow load/save/turns
PostPosted: Mon Nov 09, 2020 3:26 am 
Offline
Thalore

Joined: Thu Sep 26, 2019 4:32 pm
Posts: 147


Top
 Profile  
 
 Post subject: Re: Slow load/save/turns
PostPosted: Tue Nov 10, 2020 4:18 am 
Offline
Low Yeek

Joined: Sat Nov 07, 2020 12:13 am
Posts: 6
Sure, I'm currently running a Geforce GTX 1080 and Intel i7-6700K.


Top
 Profile  
 
 Post subject: Re: Slow load/save/turns
PostPosted: Mon Nov 16, 2020 8:32 pm 
Offline
Low Yeek

Joined: Sat Nov 07, 2020 12:13 am
Posts: 6
Although it is at a playable speed now. The graphics are still a bit weird. I tried changing versions again and it seems that 1.7.1 works fine, but something about 1.7.2 is not happy and causes the slowdown. Added a screenshot.


Attachments:
tome graphics.JPG
tome graphics.JPG [ 90.54 KiB | Viewed 854 times ]
Top
 Profile  
 
 Post subject: Re: Slow load/save/turns
PostPosted: Sun Dec 06, 2020 1:35 am 
Offline

Joined: Fri Sep 06, 2019 2:17 pm
Posts: 3
Any updates on issue? I was bit by this too... haven't played for some months, came back, and it is unplayably slow. Copied in 1.7.0 *.exe and *.dll and it is back to regular speed.

Using Windows 10, i7-8700 @3.2GHz CPU, Nvidia GeForce GTX 1080.


Top
 Profile  
 
 Post subject: Re: Slow load/save/turns
PostPosted: Sun Dec 06, 2020 2:03 am 
Offline
Thalore

Joined: Thu Sep 26, 2019 4:32 pm
Posts: 147
Thanks to all the info from people having this issue, there's a semi-solid idea of why it's happening and thus hopefully it will get eventually resolved.


Top
 Profile  
 
 Post subject: Re: Slow load/save/turns
PostPosted: Sun Dec 06, 2020 3:33 pm 
Offline

Joined: Fri Sep 06, 2019 2:17 pm
Posts: 3
That's great to hear. Are there any previews / betas one could get onto, to get to test any fixes sooner? (I'm on Steam fwiw)

I've found the swap-out-binaries-with-older-version works only to a point... had elf start, did initial level, went to sell stuff in elf town, getting Lua errors. So game unplayable for me. (although I did switch the binaries further, from 1.7.0 to 1.7.1, as the other poster... not sure if 1.7.0 would have been less problematic).


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 17 posts ]  Go to page 1, 2  Next

All times are UTC


Who is online

Users browsing this forum: Baidu [Spider] and 6 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group