ToME: the Tales of Maj'Eyal

Everything about ToME
It is currently Mon May 25, 2020 3:38 pm

All times are UTC

Post new topic Reply to topic  [ 1 post ] 
Author Message
PostPosted: Thu Jan 17, 2019 3:23 am 

Joined: Wed Aug 21, 2013 9:04 pm
Posts: 18
I had a problem with an Orc Sawbutcher on Normal Adventure mode that was probably caused by an Error Report trigger. I thought it was a permanent problem until while spending time writing this forum post with the game left open, it just fixed itself. But it generated a bug report file and I had a backed up copy of the character when the bug was still in effect, so I thought I should report it anyways (even though I already sent it online ingame). I unfortunately lost the text log when the error happened since I didn't realize it would disappear on game relaunch.

Some context on what I think might've cause this problem. There's this weird interaction between my Sawbutcher skills and the Artifact Sawblade "Stormcutter" lighting bolt trigger, in that when I use a Saw Butcher skill, I get to choose the targets of all the lightning bolts that are triggered before the actual Sawbutcher skill triggers. If I auto attack, the lightning bolts autocast as as I thought they should. This also happens with Saw Wheel's deactivated affect if i use a Sawbutcher skill to deactivate it, where hitting multiple enemies triggers several Lightning Bolts, all of which I have to target manually. I thought it was weird but didn't think much of it at the time and chalked it up to weird ToME interactions.

I'm gonna try and recount the events leading to the Error Report as accurately as I can remember
I was in the final(?) dungeon inside a Hidden Vault playing as usual. I was getting confused a lot so sometimes my actions weren't registering. When I got a Saw Butcher skill off with Saw Wheel active, I got to start choosing targets for the lightning bolts again as usual. This time though, I pressed "ESC" which would normally cancel whatever skill you were trying to pick a target for. This is when the error report triggered ingame.

After that, the Saw Wheel skill didn't deactivate on my orc for an extended period of time, whether manually or automatically by ramming into opponents. Hitting enemies, the text log says the Saw Wheel deactivates when it clearly doesn't, and I don't think I was getting the Saw Wheel deactivation affect either. The Movement speed bonus was constantly applied.
While writing this post with the game left open alt-tabbed, I tried double checking something ingame and found that the Saw wheel skill had deactivated itself and was working normally again. Apparently, all I had to do was leave the game alone for some time...?

I tried reproducing the error by pressing escape on a targetting lightning bolt after I rammed something with Saw Wheels, but it didn't cause the error. So maybe there's another factor in it happening. There were a lot of monsters in that vault at the time.

I'll attach the error report file for reference. The error file didn't have an extension at first, but i added .txt to it to be able to upload it. I also have a backed-up zip file of the character save folder for when the bug was still in effect, but I'd have to upload it elsewhere since it's 59 MB. Plus, i have no idea if the bug is reproducible that way.

The only addons I have other than all the official DLC is the "Select your Escorts" mod via Steam Workshop: ... =588789394

File comment: Error Report file
4b7908125520d3a1d28faf3c1a4b3747.txt [382 Bytes]
Downloaded 31 times
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC

Who is online

Users browsing this forum: No registered users and 5 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group