ToME: the Tales of Maj'Eyal

Everything about ToME
It is currently Tue Aug 20, 2019 12:49 am

All times are UTC




Post new topic Reply to topic  [ 11 posts ] 
Author Message
PostPosted: Sun Dec 16, 2018 12:04 am 
Offline
Wayist

Joined: Wed Mar 29, 2017 2:58 am
Posts: 17
I'm at the point in my game where I've unlocked the fortress, and the game is freezing every time I try accessing the library to populate it with all data from previous runs. The percentage completion before the freeze varies, but I ran a couple tests to look at the Lua Error in the log. Both returned the error below. It looks like the game can't find a specific entry maybe? Also, I've never had this issue on previous characters.

Lua Error: /mod/class/interface/PartyLore.lua:89: invalid value (boolean) at index 2 in table for 'concat'
At [C]:-1
At [C]:-1 render
At /mod/class/interface/PartyLore.lua:89 getLore
At /mod/class/interface/PartyLore.lua:103 learnLore
At /data/zones/shertul-fortress/grids.lua:238 check
At [string "return function(self, x, y, what, ...) local ..."]:1 checkAllEntities
At /engine/Actor.lua:243 move
At /mod/class/Actor.lua:1322 move
At /mod/class/Player.lua:312 moveDir
At /mod/class/Game.lua:2017
At /engine/KeyBind.lua:230


Top
 Profile  
 
PostPosted: Sun Dec 16, 2018 7:34 am 
Offline
Spiderkin

Joined: Wed Jan 22, 2014 1:46 pm
Posts: 465
Find world.teaw
Delete world.teaw

Library works !

it's in C:\Users\[username]\T-Engine\4.0\tome\save

_________________
I write guides and make addons too now, apparently

You can go here for a compilation of everything I wrote, plus some other important stuff!

Includes general guides (inscriptions, zone, prodigies), and class guides (Demo, Anorithil, Bulwark, Zerker, Sblade)


Top
 Profile  
 
PostPosted: Mon Dec 17, 2018 4:43 am 
Offline
Wayist

Joined: Wed Mar 29, 2017 2:58 am
Posts: 17
Thanks, I gave that a try, but it didn't work. I also noticed that world.teaw is recreated once a save file is loaded, so I even tried deleting it after loading a game for good measure. Unfortunately, the game still crashed when I tried to access the library, regardless of whether I deleted world.teaw before or after loading a save.


Top
 Profile  
 
PostPosted: Mon Dec 17, 2018 6:13 am 
Offline
Spiderkin

Joined: Wed Jan 22, 2014 1:46 pm
Posts: 465
Oh, so that's not the usual library bug and my whole knowledge of fix is copying what works for other bugs so can't help more >.>

_________________
I write guides and make addons too now, apparently

You can go here for a compilation of everything I wrote, plus some other important stuff!

Includes general guides (inscriptions, zone, prodigies), and class guides (Demo, Anorithil, Bulwark, Zerker, Sblade)


Top
 Profile  
 
PostPosted: Sun Feb 03, 2019 5:03 pm 
Offline
Yeek

Joined: Wed Dec 23, 2015 12:51 am
Posts: 13
I am having this exact same problem in 1.5.10. The te4_log.txt gives the exact same LUA error as the OP posted, character for character.

This has affected my 2 most recent characters that have gotten to the fortress. Though one is dead already. The only lore that I had collected that I know for sure for the dead one that I hadn't gotten previously is those about anti-magic, as it was the first character I had gotten to the fortress that was anti-magic. The second character is also anti-magic, but has also collected some additional lore about traps in particular from being a rogue. So I don't know if it's any of the new lore I picked up that might be doing it, or the volume of lore I have collected so far, or what.


Top
 Profile  
 
PostPosted: Mon Feb 04, 2019 5:24 am 
Offline
Yeek

Joined: Wed Dec 23, 2015 12:51 am
Posts: 13
Going to expand on this from with much of the same as I did for discord:

Quote:
Accessing the fortress library causes the game to stop working for me in 1.5.10. For the last few days it would freeze the game whilst doing the synch lore thing anywhere from 23% to 97% on the progress bar, sometimes with hearing achievement sounds. And now it seems it won't load past the mid-20%s.
While using `--flush-stdout`, this is the lua error the te4_log.txt spits out when the game stops working:

Code:
Lua Error: /mod/class/interface/PartyLore.lua:89: invalid value (boolean) at index 2 in table for 'concat'
    At [C]:-1
    At [C]:-1 render
    At /mod/class/interface/PartyLore.lua:89 getLore
    At /mod/class/interface/PartyLore.lua:103 learnLore
    At /data/zones/shertul-fortress/grids.lua:238 check
    At [string "return function(self, x, y, what, ...) local ..."]:1 checkAllEntities
    At /engine/Actor.lua:243 move
    At /mod/class/Actor.lua:1322 move
    At /mod/class/Player.lua:312 moveDir
    At /mod/class/Game.lua:2017
    At /engine/KeyBind.lua:230
FROM     /mod/addons/cults/superload/engine/dialogs/ShowErrorStack.lua    loading previous!


This is what comes right before the lua error about 60% of the time, no matter the progress bar percentage the game stops working at:

Code:
[LOG]    Lore found: #0080FF#Nature vs Magic
[PROFILE] filtering save of     lore     to profile     online
[PROFILE] mounted     online    on /current-profile
[PROFILE] unmounted     online    from /current-profile
[LORE] learnt    nature-vs-magic
[ENGINE] Setting requested FPS to 30 (33 ms)
[ENGINE] Setting requested FPS to 30 (33 ms)



Deleting world.teaw does nothing. The "new" world.teaw generated after deleting it just makes the exact same file with same checksums.


Top
 Profile  
 
PostPosted: Tue Feb 12, 2019 3:51 am 
Offline
Wayist

Joined: Wed Mar 29, 2017 2:58 am
Posts: 17
I'm onto my third character since I originally reported this bug, and each of the three characters runs into the same issue at the fortress. The LUA error is the same, and deleting world.teaw still doesn't do the trick. I see that c2t first encountered the issue after getting to the fortress with an anti-magic character for the first time, and I can report that this was true for me as well. It's interesting to think that the related lore could potentially be the problem since a lot of people should be having the problem if it is, but it's definitely a common thread between the two of us. However, for me, only that first character was anti-magic.


Top
 Profile  
 
PostPosted: Wed Feb 13, 2019 2:16 am 
Offline
Yeek

Joined: Wed Dec 23, 2015 12:51 am
Posts: 13
So, I have figured out how to truly delete world.teaw. My issue with removing it was Steam, the Steam cloud, and how the game interacts with the cloud. Simply disabling Steam cloud doesn't work, and even is a non-option for me as the cloud cannot be disabled for individual games anymore. It was quite the involved process to isolate the cause and actually remove it for real. I will PM you a rough draft of what I am planning to post at some point to maybe help you with it if you are also playing through Steam.

All that said though, this doesn't alleviate the trigger for whatever causes the library thing to start happening. However, I'm not so sure it would be so simple to figure out. I do have the old world.teaw that was causing me issues if anyone is interested in that.


Last edited by c2t on Wed Feb 13, 2019 3:09 am, edited 1 time in total.

Top
 Profile  
 
PostPosted: Wed Feb 13, 2019 3:03 am 
Offline
Wayist

Joined: Wed Mar 29, 2017 2:58 am
Posts: 17
I'm posting to confirm that Steam proves to have been the issue for me as well. Thanks again for your help c2t!


Top
 Profile  
 
PostPosted: Wed Feb 13, 2019 6:46 am 
Offline
Yeek

Joined: Wed Dec 23, 2015 12:51 am
Posts: 13
For benefit of those finding this through search or whatever: information on how to delete "world.teaw" while using Steam and its cloud can be found at the one of the following:
viewtopic.php?f=41&t=49412
https://steamcommunity.com/sharedfiles/ ... 1654106093

Though it'd be better to not have to at all :P


Top
 Profile  
 
PostPosted: Fri Apr 19, 2019 6:33 pm 
Offline
Wayist

Joined: Wed Mar 29, 2017 2:58 am
Posts: 17
I have a couple updates related to this that I thought I should post.

First, while deleting world.teaw does resolve the library issue on the current run, the issue recurs on subsequent characters. This is true even if I disable Steam cloud saves, as Cathbald suggested in the thread c2t linked above. I'm still leaving cloud saves off as it seems to be a good idea.

Second, manipulating world.teaw to deal with the library issue has other consequences: namely that it resets progress on achievements that are tracked across multiple characters. I was able to confirm that deleting world.teaw reset Reaver and A Fistful of Demons on my current character, and I would presume Pyromancer and Cryomancer are also affected. I checked achievement progress very soon after deleting world.teaw to allow the library to load. My count for Reaver was only 14, and my count for A Fistful of Demons was 0 despite finally getting the Doomelf unlock on this character. I tried restoring the deleted world.teaw from my recycle bin, and when I reloaded the save, Reaver and A Fistful of Demons were again reflecting progress that was more in line with what I expected (500+ for Reaver and 60+ for Demons).

As such, tracking multi-character achievements must be one of the functions of world.teaw, which is worth keeping in mind if you care about getting those achievements like I do. Of course, fixing the library also allows you to get the lore achievements more easily when doing a higher difficultly level for the first time, so if you are experiencing this bug, you may want to choose which type of achievement to focus on first if they matter to you. Personally, I'm going to make sure I get those kill count and damage achievements in Insane Roguelike before bothering world.teaw again, although I'll also check to see if the library works normally for me whenever 1.6 comes out.

One other note is that restoring the older world.teaw file on my current character reverted to library back to its unloaded state, where it again freezes the game. I also found that I now get a Lua error when trying to check known lore through the normal menu, though I'd suspect that's a result of messing with world.teaw so much.

Edit: I forgot to note that I also checked single character achievements, and those are not affected by world.teaw. Guiding Light, for example, was correct at 6 escorts saved before and after I messed with world.teaw. Other single character achievements had reasonable progress.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 11 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group