ToME: the Tales of Maj'Eyal

Everything about ToME
It is currently Thu Nov 21, 2019 6:40 pm

All times are UTC




Post new topic Reply to topic  [ 2 posts ] 
Author Message
PostPosted: Mon Nov 12, 2018 10:58 pm 
Offline

Joined: Mon Nov 12, 2018 10:51 pm
Posts: 1
I already did send this through the game but the sticky topic says post it here, too.

Basically what happened is I was going through the old forest as a rogue, and uncovered a trap. I used the Disarm Trap spell, and it was successful. After that, trying to rest (or autoexplore) gave the message "Trap has been disarmed". I quit the game, and upon returning, trying to rest (or autoexplore) tosses out this dump:

[LOG] Resting starts...
Lua Error: /mod/class/Trap.lua:202: attempt to compare nil with number
At [C]:-1 __le
At /mod/class/Trap.lua:202 restCheck
At /engine/interface/PlayerRest.lua:47 restInit
At /mod/class/Game.lua:2142
At /engine/KeyBind.lua:236

One other thing I noticed (I went back to the Old Forest looking for more traps, maybe to reset it? I dunno) was that enemies being in range didn't seem to stop the character from entering stealth mode.


Top
 Profile  
 
PostPosted: Thu Dec 20, 2018 9:17 pm 
Offline
Higher

Joined: Wed Jun 06, 2018 10:53 am
Posts: 61
I encountered this issue as well, no error though. That character was also a rogue (I don't remember what race). I tried to disarm a trap in a vault with no luck. Then it disappeared (disarmed?) and that character lost his ability to rest and auto-explore.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC


Who is online

Users browsing this forum: Snarvid and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group