ToME: the Tales of Maj'Eyal
http://forums.te4.org/

Can't load after new update (GOG)
http://forums.te4.org/viewtopic.php?f=42&t=48835
Page 1 of 1

Author:  Legend_Odinson [ Tue May 01, 2018 8:03 pm ]
Post subject:  Can't load after new update (GOG)

I just updated the game and expansions on my gog version of the game, but when I try to run it, I get an error that states:

r-engine.exe - entry point not found
"The procedure entry point k32getmodulefilenameexw could not be located in the dynamic link library kernel32.dll"

The game started after I clicked "ok", but when I tried to load a saved game, it just hung on a black screen. I was luckily able to alt tab out of that.

But when I instead tried to start a new game, it just froze on a black screen and I had to do a hard reset.

I tried deleting my old folder and doing a complete fresh re-installation, but the problem persists. Never had any issue like this before.

I'm on winxp sp3.

Thanks.

(P.s: I think I accidentally posted this in the wrong thread at first.)

Author:  darkgod [ Tue May 01, 2018 8:39 pm ]
Post subject:  Re: Can't load after new update (GOG)

Which was the last version that worked ? 1.5.7 ?
Please also try to move away the whole of c:/users/<yourname>/t-engine/4.0 folder (if you're on windows). This holds all settings & saves

Author:  Legend_Odinson [ Tue May 01, 2018 11:00 pm ]
Post subject:  Re: Can't load after new update (GOG)

darkgod wrote:
Which was the last version that worked ? 1.5.7 ?
Please also try to move away the whole of c:/users/<yourname>/t-engine/4.0 folder (if you're on windows). This holds all settings & saves


The last version that worked fine was previous to 1.5.7. 1.5.7 was the update that introduced this issue for me. (I didn't realize that 1.5.8 came out just a few days ago after I tried 1.5.7)

I did a complete uninstall and reinstall of the game as well. But no luck.

I have no such folder on my computer. just c:/users/public. And no t-engine folder within. I have had it installed on an external drive like most my games.

Author:  Legend_Odinson [ Fri May 04, 2018 1:36 am ]
Post subject:  Re: Can't load after new update (GOG)

I located a t-engine folder in the My documents folder and removed it. I still seem to get the same error unfortunately. I'm on windows xp with service pack 3.

Author:  Legend_Odinson [ Tue May 15, 2018 1:22 am ]
Post subject:  Re: Can't load after new update (GOG)

I just tried the 1.5.9 patch and I still get the kernal 32 error.

Author:  Frumple [ Wed May 16, 2018 4:36 pm ]
Post subject:  Re: Can't load after new update (GOG)

Getting the same here on vista, though not the GOG version. Last version I know didn't have the error was 1.5.5, and I first noticed it happening with 1.5.8 (and still happening with .9).

That said, with 1.5.9 it seems to be loading despite throwing up the kernel error; 1.5.8 crashed saying something about birther.lua when it tried to load a new game. To the extent it helps any I have pretty much everything graphics wise disabled I can disable without actually mucking with the game's files, which might be what's letting me play anyway.

Author:  darkgod [ Fri May 18, 2018 8:43 am ]
Post subject:  Re: Can't load after new update (GOG)

One of you please try to say my name either ingame, IRC or discord a few times to make me appear if I'm around. I'll need some realtime debugging

Page 1 of 1 All times are UTC
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/