ToME: the Tales of Maj'Eyal
http://forums.te4.org/

The shaders options don't seem to work, period
http://forums.te4.org/viewtopic.php?f=42&t=48808
Page 1 of 1

Author:  Skyknight [ Mon Apr 23, 2018 7:41 pm ]
Post subject:  The shaders options don't seem to work, period

(EDIT: Bah, just realized the subject was misleading. Have changed.)

I wouldn't be surprised if this is not a bug so much as a hardware limitation, admittedly. Basically, distortion effects (e.g. Unhallowed Morass) and certain other visual effects (e.g. gleaming water, necrotic zones being black nimbuses rather than circling whitish motes, flame wings on wyrmic when using Wing Buffet) don't manifest at all on my machine (2012 Toshiba Satellite C855-S5350). They did manifest on my old 2007 iMac, however. The iMac used an ATI Radeon 2600 PRO, while this machine uses a standard Intel HD Graphics (no number that I could find...). Would that be enough to explain it, or is there a genuine bug at work?

Author:  HousePet [ Tue Apr 24, 2018 12:02 am ]
Post subject:  Re: The shaders options don't seem to work, period

All the shaders rely on OpenGL, so if your graphics processor doesn't properly support it, they won't work.
Try the instructions on this page to check what version of OpenGL is supported: https://www.intel.com.au/content/www/au ... ivers.html
You might need to update the drivers.

Author:  Skyknight [ Tue Apr 24, 2018 1:22 am ]
Post subject:  Re: The shaders options don't seem to work, period

I checked the Graphics Control Panel...only to find it's not listing an OpenGL version at all. It lists DirectX as 11.0, well enough, but OpenGL's doing a nice job of hiding from me...

The graphics driver for Intel(R) HD Graphics seems to be up to date (May 2016), according to Device Manager.

{sigh} It may have gone for just $700 pre-discount, but I'd expect a 2012 machine to be completely competent at 2D graphics.

Author:  HousePet [ Tue Apr 24, 2018 5:04 am ]
Post subject:  Re: The shaders options don't seem to work, period

This program might give more information: http://download.cnet.com/OpenGL-Extensi ... 34442.html

Author:  Skyknight [ Tue Apr 24, 2018 6:04 pm ]
Post subject:  Re: The shaders options don't seem to work, period

Found it! Current OpenGL version is 3.1...and I can't figure out how to update it. In fact, Intel's on-site update checker says I don't have any updates available for my graphics driver. The processor, for the record, is a Pentium CPU B980; apparently it's a dual core. What do further versions of OpenGL (like 4.5, although the Extension Viewer said that everything from 3.2 onwards is incompatible...somehow) require?

Author:  HousePet [ Wed Apr 25, 2018 12:42 am ]
Post subject:  Re: The shaders options don't seem to work, period

Unfortunately it is not possible to update OpenGL functionality due to it being embedded in your graphics drivers.
You only need up to version 2.1 for everything ToME uses, so I'm not sure what is going wrong.
All I can think of is that it has decided not to use the graphics driver functions for whatever reason, or there is a fault with the current drivers.
Perhaps try:
Checking if you can force the system to use maximum graphics power for the program. Sometimes laptops don't enable full graphics as a power saving feature. (or in the case of my current one, runs the real graphics card to render Solitaire...)
Roll back the graphics drivers for an earlier version.
Contact Intel support about it.

Page 1 of 1 All times are UTC
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/