ToME: the Tales of Maj'Eyal

Everything about ToME
It is currently Wed Jan 27, 2021 1:44 am

All times are UTC

Post new topic Reply to topic  [ 4 posts ] 
Author Message
 Post subject: Weird Graphical Issue
PostPosted: Thu Jan 18, 2018 10:10 pm 

Joined: Thu Jan 18, 2018 9:41 pm
Posts: 3
I seem to have a problem with textures/tiles overriding others, they still behave as they would but appear otherwise (ie, a grass tile will look like water but I won't drown) It's mainly been water textures overriding grass tiles but their are a handful of specific areas where grass will override walls (Yeek start location is one).

I run it through steam, I have verified integrity of the game files, I'v done a complete uninstall/reinstall, I'v made sure I have no conflicting mods. Nothing seems to fix this issue. The game does otherwise run as expected, there are no crashes/error messages.

PostPosted: Wed May 23, 2018 2:18 pm 

Joined: Wed May 23, 2018 2:09 pm
Posts: 2
I'm encountering this bug as well.
It's making the game fairly hard to play.

I just installed for the first time on Steam.
Screenshot of problem ... 1392795520

I have a Intel UHD Graphics 620
I have the latest driver version installed

What additional information would you need from me to diagnose this problem?

PostPosted: Thu May 24, 2018 8:04 am 
Master of Eyal

Joined: Wed Jul 24, 2002 9:26 pm
Posts: 10738
Location: Angolwen
I am so lost lol ...
Does the water have the water animation where it moves? What does the tooltip says?
ALso can you zip me up the savefile please?

[tome] joylove: You can't just release an expansion like one would release a Kraken XD
[tome] phantomfrettchen: your ability not to tease anyone is simply stunning ;)

PostPosted: Thu May 24, 2018 9:50 am 

Joined: Wed May 23, 2018 2:09 pm
Posts: 2
Thanks Darkgod,

I was new to the game and a little confused by the tiles.
Yes the water tiles do animate when the glitch is present.

I've tried a range of resolutions and video settings.
Turning "OpenGL Shaders Off" resolves the misplaced water tiles and the water does not animate. (It's kind of obvious as the note next to this option states 'if you encounter weird graphical glitches turn this off')

Resolution was not related to the issue. It manifested at 1080p and 720p with OpenGL Shaders On.

The game model is working fine - it's just the graphical display that was twitchy.
I don't think a savefile will assist as I was able to load the same savegame and not reproduce the issue with the Shaders off.

I think this must be related to the OpenGL implementation of the Intel driverset.
It may be worth investigating the issue further as this is a fairly common integrated graphics chipset on modern machines.

Once I fiddled around the game is now playable and less confusing. It just took me by surprise as a new user.
I'm really looking forward to exploring TOME. I've been a fan of ADOM for many years and deciding to branch out.

Thanks again for taking the time to reply. You clearly are a professional.
Let me know if I can provide more information for you.

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC

Who is online

Users browsing this forum: Google [Bot] and 11 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group