ToME: the Tales of Maj'Eyal

Everything about ToME
It is currently Thu Dec 12, 2019 10:32 am

All times are UTC




Post new topic Reply to topic  [ 2 posts ] 
Author Message
PostPosted: Tue Jul 25, 2017 3:55 am 
Offline

Joined: Tue Jul 25, 2017 3:50 am
Posts: 1
So, today I was playing a ghoul bulwark and invested into the galvanic retributor (yes that all sounds like a terrible combo) and I found something interesting... the retributor doesn't go into the tinker slot like other tinkers, but applies directly to the shield and then says 'failed to apply tinker'.

This can be done an infinite number of times, and persists when the shield is taken and put back into the inventory.

HOWEVER, this only happened with one specific shield-- when I tried it with other shields the item worked just fine. Swapping back to the bugged shield would forcibly de-equip the galvinator (and apply it to the bugged shield again). So it's probably something to do with the shields egos (cosmic?).

https://gyazo.com/92dfd00772cc3dcd46f5a6e0ee5a53af

Here's the shield in question... notice the stacking lightning damage on hit.


Top
 Profile  
 
PostPosted: Tue Jul 25, 2017 9:45 pm 
Offline
Thalore

Joined: Mon Feb 13, 2017 4:43 pm
Posts: 152
The problem the tinker has is that the shield has a on-block effect. Some stuff in the code gets messed up there because the game checks to make sure it doesn't override the previous on-block and... well, it applies the stats, then sees "oh shit, I can't attach because the shield already has on-block" and thus just goes back into your inventory.

So yeah, it's a bug that's specific to shields with on-block effects.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC


Who is online

Users browsing this forum: Bing [Bot] and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group